I already have a script on my page, and I copied the info block from that script, but for some reason I'm getting a 404 "Selected file is not JavaScript." error when I try to upload it... Any idea why?

// ==UserScript==
// @namespace    https://openuserjs.org/users/Mr_FJ
// @name         RockPaperShotgun anti-anti-adblock
// @description  Removes RockPaperShotgun's anti-adblock bullsh*t.
// @copyright    2019, Mr_FJ (https://openuserjs.org/users/Mr_FJ)
// @grant        none
// @license      MIT
// @version      1.0
// @updateURL    https://openuserjs.org/meta/Mr_FJ/RPSAntiAntiAdblock.meta.js
// @downloadURL  https://openuserjs.org/install/Mr_FJ/RPSAntiAntiAdblock.user.js
// @match        https://www.rockpapershotgun.com/*
// ==/UserScript==

// ==OpenUserJS==
// @author Mr_FJ
// ==/OpenUserJS==

function addGlobalStyle(css) {
    var head, style;
    head = document.getElementsByTagName('head')[0];
    if (!head) { return; }
    style = document.createElement('style');
    style.type = 'text/css';
    style.innerHTML = css;
(function() {
    setTimeout(function() {
        addGlobalStyle('.no-js { overflow-y: visible !important;}');
        addGlobalStyle('.ads-enabled { overflow-y: visible !important;}');
        var element = document.querySelectorAll('div[class*="sp_message_container"]');
        Array.prototype.forEach.call( element, function( node ) {
            node.parentNode.removeChild( node );
        var element2 = document.querySelectorAll('div[class*="sp_veil"]');
        Array.prototype.forEach.call( element2, function( node ) {
            node.parentNode.removeChild( node );
     }, 5000);

Re: @Mr_FJ:

Any idea why?

Nope. Works for me. Try a different browser and/or a clean profile... then try again?

OUJS Admin

Adding it using the ditor instead of as a file seems to have worked, too bad the filename is not as clean.

Re: @Mr_FJ:

I copied the info block from that script

Re: @Mr_FJ:

Adding it using the (e)ditor instead of as a file seems to have worked

Copied vs. upload is a little different story. I'm in the middle of rebuilding dev station and it will probably be another day before things are even remotely set to look for fixes possibly in our deps... possibly in the browsers sending the incorrect MIME type... idk yet.

Anyhow... confirmed with File upload in a "dirty" profile in this browser.

Re: @Mr_FJ:

... too bad the filename is not as clean.

It is "clean" but the browsers are arguing again on standards. We've made an exception at #1599. You should be good to go.

Just a note... while I do check here on occasion... it is best to use the Development link below on every page to create an issue if you think it's an actual bug.

Thanks for the report.
OUJS Admin