BastianKanaan Author


Das sind Anpassungen für die Dialoge, wie z.B. Preise, Lager, Markt (Sprung zum Händler)


Re: @linus--tux:
Ja, weiß ich. Eigentlich sollte per WebHook auch ein automatisches Updaten stattfinden. Das funktioniert aber nicht mehr.
Außerdem sagt er neuerdings "File size is larger than maximum (1048576 bytes)." und will den Berater nicht mehr rüberladen.

Ich bin diese Problemchen ehrlich gesagt Leid. Wenn ich etwas Zeit finde, setze ich ein kostenfreies Forum auf. Dort ist dann auch besseres Foren-Threading möglich als hier.
Installation ist außerdem auch direkt aus GitHub möglich, so dass ein Rüberladen eigentlich gar nicht notwendig sein müsste:
https://raw.githubusercontent.com/BastianKanaan/GMscripts_MyFreeFarm/master/MyFreeFarm_Berater.user.js
https://raw.githubusercontent.com/BastianKanaan/GMscripts_MyFreeFarm/master/MyFreeFarm_Automat.user.js


Hallo Leute,
ich habe eine neue Version von Berater und Automat auf GitHub hochgeladen.
Leider funktioniert das Laden auf diese Seite irgendwie nicht mehr. Ich glaube, ich setze mal ein eigenes freies Forum auf (Vorschläge?).

Die Installation müsste direkt von GitHub funktionieren:
https://github.com/BastianKanaan/GMscripts_MyFreeFarm -> Skript anklicken -> "Raw" anklicken -> installieren

Die Änderungen von linus--tux habe ich noch nicht gesichtet. Am besten wäre es, wenn du die Änderung im GitHub machst und per Pull Request einspielst. Danke.

Viele Grüße,
Bastian






Ihr müsst die Option "Block the cropping of sleeping fields." im Automaten aktivieren, damit der Bot das Ernten unterlässt.


Bitte in GitHub genau als Issue einstellen.
Ich werde mich mit diesem Thema aber vorerst nicht befassen.



Ich habe jetzt eine Lösung.
Ich möchte aber noch etwas testen, sodass ich wohl heute Abend den Upload mache.
Auf GitHub ist sie bereits zu finden.


Ich glaube, dass Firefox 35 bei mir wieder Probleme verursacht ... Also bitte nicht installieren bzw bitte bestätigen ;-) .

Vielleicht kann auch jemand bei der Behebung behilflich sein? Die Sicherheit hat evtl wieder zugeschlagen -.-


Re: @purzel:

Das Problem der Konversationen habe ich als Bug aufgenommen. Das sollte korrigiert werden.

Um die Sprachpakete möchte ich mich nicht kümmern. Vielleicht kannst du das für Dänisch tun?


Ja, das möchte ich auch gerne haben. Nach meinem letzten Wissensstand liegen aber nicht alle Daten vor, die benötigt werden.
Das Datenspeicherkonzept müsste also erweitert werden oder Hintergrundabfragen ausgeführt werden (möchte ich sehr ungern).



This is my working function now:

function click(node){
    var evt=new MouseEvent('click',{'view':window,'bubbles':true,'cancelable':true});
    node.dispatchEvent(evt);
}

The problem of my script was another one (security change of FF 30/31).



  1. Muss ich mir wohl mal ansehen.
  2. Ja, hier will ich noch irgendwas machen.
  3. Habe ich nicht vor.

Well, basically I supporty only the latest version.

Try to reinstall the Berater now. Does this fix work?





Hello,

my scripts broke by the current changes of FF/GM.
One problem is the dispatching of mouse clicks.
My old function:

function click(node){
var evt = document.createEvent("MouseEvents");
evt.initEvent("click", true, true);
node.dispatchEvent(evt);
}

Can anyone here help me how I have to create a click event now?
Thanks in advance!